Found GPU0 GeForce GTX 960M which is of cuda capability 5.0

when I run the model, it returns me"Found GPU0 GeForce GTX 960M which is of cuda capability 5.0"

I saw someone say I need to compile from source.

But I’m new in pytorch. I do not get that point. Could I have a step by step tutorial to solve this problem?
Thanks a lot!!!

From this thread:

Compiling from source is pretty straight-forward. You can find the instructions here. Let me know, if you have any trouble with it.

It seems I have the same problem, but I am on Windows. Would you please tell me if there is a similar solution?

I’m not familiar with the Windows build system, but it seems @peterjc123 has some information on how to resolve your issue in his repo.
Apparently you can install some of his builds with minor dependency tweaks.

I reinstalled previous versions of pytorch, cuda, cudaDll and VS and it’s working. Thanks guys.


I am new to conda. I am trying to work with an environment from fastai.

How can I replace the current Pytorch installed from package with the one complied from source?


If you need to build PyTorch from source, I would remove it from the environment file, create the conda environment, activate it and finally build PyTorch in from source using the activated environment.

However, I’m wondering, if you really need to build PyTorch from source for the fastai lectures.
What is your use case for this?

Hello, I followed the instructions to install the fastai environment. However, while running the lesson1.ipynb, I got the following error when trying to use Pytorch.

Blockquote Found GPU0 GeForce GTX 960M which is of cuda capability 5.0.
PyTorch no longer supports this GPU because it is too old.

Ah ok, I understand. Did you manage to install all dependencies using my suggestion?

Trying now. I’ll let you know.

I uninstalled the package from the environment. Then build pytorch as instructed. It is working.

Thank you @ptrblck.

I was getting the same on Ubuntu 18.04 with CUDA 9.1. I found that setting up a new environment, with

conda install pytorch torchvision cuda91 -c pytorch

rather than letting it sort out it’s own dependancies.

Worked for me.

can anyone help me in installing the old version of pytorch in my windows machine.

I am doing fastai courses and i am getting following error.

RuntimeError: cuda runtime error (48) : no kernel image is available for execution on the device at c:\anaconda2\conda-bld\pytorch_1519501749874\work\torch\lib\thc\generic/

I know solution is already provided by peterjc123 But i dont know how to use the solution, please help