Freezing at "Using /home/user/.cache/torch_extensions as PyTorch extensions root..."

HELP!
the program seems to just stop with once “Using /home/user/.cache/torch_extensions as PyTorch extensions root…” prints

Could you describe the use case and issue a bit more? When are you running into this hang and would it be possible to post a minimal code snippet to reproduce the issue?
Also, could you update PyTorch to the latest release, if you are using an older one?

Hi,as shown in the figure, there is no error message.

I use 3090, and the CUDA version is 11.1. I tried to update my pytorch from 1.7 to 1.9, it still hasn’t been resolved.

Thanks for the update. I don’t think you are seeing a hang, but just a runtime compilation of an extension.

Hi, I waited for it 3.5 hours. However, it still stops here. :rofl:

OK, that doesn’t sound right. :stuck_out_tongue: Try to narrow down which extension is being built and then maybe run it in isolation (or pre-built it to check, if this would be working).

there may be a leftover .lock file from aborted build, try cleaning either whole .cache or extension’s sub-directory, I don’t remember where this file appears, but I had a hang because of it

4 Likes

I deleted the whole .cache, and it works now. :speak_no_evil:

1 Like