Help SD on Mac M1 Pro

Dear Sir, All

I use Code about Stable Diffusion WebUI AUTOMATIC1111 on Mac M1 Pro 2021 (without GPU) , when I run then have 2 error :

  1. Launching Web UI with arguments: --skip-torch-cuda-test --upcast-sampling --no-half-vae --use-cpu interrogate

no module ‘xformers’. Processing without…

no module ‘xformers’. Processing without…

No module ‘xformers’. Proceeding without it.

Warning: caught exception ‘Torch not compiled with CUDA enabled’, memory monitor disabled

  1. RuntimeError: MPS backend out of memory (MPS allocated: 9.93 GB, other allocations: 2.03 GB, max allowed: 18.13 GB). Tried to allocate 7.43 GB on private pool. Use PYTORCH_MPS_HIGH_WATERMARK_RATIO=0.0 to disable upper limit for memory allocations (may cause system failure).

I try install Torch, Tensoflow to active GPU (virtual) and check have GPU, but the same error, this is file web-user.bat :

git pull

@ echo off


set GIT=


set COMMANDLINE_ARGS= --xformers --autolaunch --skip-version-check --precision full --no-half --skip-torch-cuda-test --listen --port 9999 --disable-safe-unpickle --deepdanbooru

call webui.bat

Pls help me, many thanks

Hi, have you found the solution?

same exact problem, have you found any solutions?
are you running on an MBP M1 base?