Help with ModuleNotFoundError: No module named 'Dataloader' !pip not working

I am very new to Python and need some help. I keep getting the error message, “ModuleNotFoundError: No module named ‘Dataloader’.” I have tried manually installing dependencies using !pip, but that is not correcting the error either. I have included a screenshot of the error message below.

I would greatly appreciate any support with correcting this error message I keep getting. Thank you in advance!

DataLoader it not a top-level module in PyTorch and you can import it via from torch.utils.data import DataLoader.
The MultiEpochsDataLoader seems to be defined in here: https://github.com/huggingface/pytorch-image-models/blob/b5a4fa9c3be6ac732807db7e87d176f5e4fc06f1/timm/data/loader.py#L314 so you might want to fix your imports.

1 Like

@ptrblck Thank you for your quick reply! I appreciate your help!

This is my imports section and I believe I have the DataLoader aspect put in correctly.

I will look into the MultiEpochsDataLoader part to see if that gets me closer to my end goal.

Thanks again!