How can I install a low-version pytorch with my high-version CUDA

My CUDA version is 11.8. And I want to run a deep learning model which proposed a few years ago.
In the README file of the model, it runs on pytorch1.6, but when I look into the pytorch previous version website(Previous PyTorch Versions | PyTorch). I only found commands of CUDA 9.2 10.1 10.2. In addition, I found that previous version of pytorch(below 1.6), I have to add cudatoolkit in my command. Why I don’t have to add this in recent version?
Anyway, how can I or can I install pytoch1.6 when my CUDA is 11.8, in order to reimplement a deep learning model.

This is a question disturbs me at a long time, hopefully someone could help me.

Build processes and dependencies as well as package names change over the years. You could check the history in pytorch/builder when and why it was changed.

Your locally CUDA toolkit won’t be used by the PyTorch binaries as they ship with their own dependencies. If you thus want to use an ancient PyTorch release with its corresponding CUDA version, you could just install it. However, if you want to build an old PyTorch version with a new CUDA toolkit from source, you would need to cherry-pick all needed CUDA-related changes into the old PyTorch branch as the build will most likely fail.

That sounds rather complicated. I guess a better way is to either only use cpu to do my reimplement or use a high-version pytorch(perhaps change some api)

Yes, the best option would be to make your PyTorch code compatible with the latest release and use PyTorch 2.1.1 or the latest nightly.

I see. Thank you!Perhaps i would choose to use cpuOnly to do my reimplement :grinning: