How to install pytorch with cuda8.0?

I’ve tried this command,

conda install pytorch=0.4.1 cuda80 -c pytorch

But when I use the torch it will say “CUDA driver version is insufficient for CUDA runtime version”.

Then I tried to download the whl from, but I can not open the website.

1 Like

Have a look at the Compatible driver versions and make sure you are satisfying the minimal driver version.

Actually I have checked it, seems no problem with the driver version.
Other users and applications work well. I just could not install pytorch.

Which driver are you currently using?
nvidia-smi will show you the driver version on top.

Driver version – 375.51
nvcc --version – V8.0.61

Thanks for the information.
The CUDA version given by nvcc won’t be used, as PyTorch binaries ship with their own CUDA and cudnn libs.

Do you necessarily need this old PyTorch version (0.4.1) or could you try to install the latest stable version (1.2.0) with CUDA9.2 or CUDA10?

Thanks for your patience.
you mean “conda install pytorch torchvision cudatoolkit=9.2 -c pytorch”?
I‘ve tried it, but when I use torch, it will warn me that my driver version is too old.
If I type “conda install pytorch torchvision cudatoolkit=8.0 -c pytorch”, then under this channel cudatoolkit8.0 can not be found.

In that case, I would suggest to update the drivers and use the latest version.
Note that you should use CUDA10.0, if you have a Turing GPU (e.g. RTX2080).

Actually I can not update the driver because the server is managed by others. Maybe I can suggest him to update it, but I think it will take quite a time.
Thanks for your advice anyway~ It is so kind of you :)

1 Like