How to switch to older version of pytorch?

I have a problem with version 0.4 and what to go back to version 0.3.
How I can do that?

I checked the follwoing link ( but when i run the command:
torch-0.3.1-cp36-cp36m-linux_x86_64.whl is not a supported wheel on this platform.

it gives me this error:

torch-0.3.1-cp36-cp36m-linux_x86_64.whl is not a supported wheel on this platform.

Are you using conda?
If so, try:

conda install -c pytorch pytorch=0.3.1

I am trying to install the version 0.3.0 in Ubuntu and I have installed cuda 10 in it. Can you help me out?

CUDA 10 ships only with the 1.0.0 binaries as far as I know.
If you need 0.3.0 you would have to build from source as described here.
The highest CUDA version for 0.3.0 seems to be CUDA9.0.


I dont think version 0.3 works with cuda 10. I remember I had to do it with cuda 9.0

1 Like


It is possible to use 2 différent version of pytorch in the same programme?
Because I have a part of my code that works in pytorch 0.3.1 and an other works in the latest version (1.0) and it’s difficult to readjust on code versio to other.

Thank you for you help

You need to take a look at PyTorch 0.4.0 Migration Guide to make sure the changes are taken into consideration. In general, I don’t thin it is a good idea to merge two code from different version with each other

Ok thank you,

When I use my older code into the new version of pytorch (0.4.0), all my code don’t work, but it’s very long to recoding again :confused:

Hy sir am downloading the torch version 1.1.0 with cud 9.0 but its giving an error that cuoldnt download but when i am downloading the latest version it is down loading it and i have the GTX 1050 KINDLY help me that how to download the torch version 1.1.0 with cuda9.0 with GTX 1050 Nvidia.

And moreover i am doing it in windows.

Could you post the error?
What does this command output?

conda install pytorch==1.1.0 torchvision==0.3.0 cudatoolkit=9.0 -c pytorch
1 Like

Am not using the conda am using pycharm terminal for the installation with OSX which is mention in screen shot below

the cuda 9.2 with latest version of torch is working but i need 1.1.0 kindly help me how to switch on the older one

I’m unfortunately not familiar with PyCharm and don’t know, what the pycharm terminal is. :confused:

ok but sir when i used google colab its giving error of argument parser which creates confliction with the jupyter which ide you will prefer for the development or you using?

What kind of error are you getting on Colab?
I’m using a local conda environment to manage my installs. :wink:

Hello, I have neural network trained on older version of PyTorch that need to run.
Apparently, the appropriate version is PyTorch 0.3.1. Can you please share a piece of advice is that even possible anymore since I am having way too many conflicts to downgrade everything in order to be able to install PyTorch 0.3.1. I am running Ubuntu 18.04 and using conda environments.

P.S. I’ve used the same code and datasets to train the network with the newest PyTorch version and it doesn’t produce the same results as the one that is provided on the repository. Apparently, if you train the same network with new libraries, the results are different.

Thank you.

I would not recommend to downgrade PyTorch to 0.3.1, as this version is too old by now.

Based on your description, I assume you already have an executable code in PyTorch 1.5.0 or the nightly binaries?
If so, do you see any warnings raised during execution?
How large is the difference and what are you comparing at the moment (final accuracy etc.)?

Since your last response, I have tried numerous ways to downgrade, and it was extremely inconvenient process. I didn’t have sucess in the end, so decided to listen your advice and just rerun/refactor everything with new version.

how do I make sure that it uses gpu or a specific cua version?

Your original command

conda install -c pytorch pytorch=0.3.1 

would this one work?

conda install pytorch==1.6.0 torchvision cudatoolkit=10.2 -c pytorch

asking due to DDP deadlocks: Call to CUDA function failed. with DDP using 4 GPUs · Issue #54550 · pytorch/pytorch · GitHub

SO question: python - How to install older version of pytorch - Stack Overflow