How to use old GPU with pytorch

My question is simple, just as said above. I installed pytorch days before, and I found one message below when running some code about C3D training and prediction:

/home/zephyr/anaconda3/lib/python3.6/site-packages/torch/cuda/ UserWarning:
Found GPU0 GeForce GTX 960M which is of cuda capability 5.0.
PyTorch no longer supports this GPU because it is too old.

So is there any possible ways that I could still use this GPU? Maybe some older version of PYTORCH?

Thank you for all the possible solutions!


You can compile pytorch from source to be able to use this gpu at the moment.

Hello, thanks for your suggestion! I tried to compile from source following instructions in the website, but I met another error now:

/home/zephyr/anaconda3/compiler_compat/ld: cannot find -lpthread
/home/zephyr/anaconda3/compiler_compat/ld: cannot find -lc
collect2: error: ld returned 1 exit status
error: command ‘gcc’ failed with exit status 1

I uninstalled the older pytorch version first, and tried to compile it from scratch. But when I used the to install, such error occurred.

Do you know what I could do then? Thank you very much!

It seems like you are missing some libraries on your operating system.
You might want to install the developement version of libc which would be a package like glibc-dev or libc-dev depending on your distro.

Thank you again for your reply and help, my problem got solved days before!