I got a dimension error to detect objects through Yolo

Hi guys!
I have a problem when I try to dectect objects in my video, using Pytorch & Code [github repo]d(https://github.com/ayooshkathuria/YOLO_v3_tutorial_from_scratch).

When I run video.py, I see an error as below.
C:\Users\Playdata\Anaconda3\lib\site-packages\torch\nn\modules\upsampling.py:129: UserWarning: nn.Upsample is deprecated. Use nn.functional.interpolate instead.
warnings.warn(“nn.{} is deprecated. Use nn.functional.interpolate instead.”.format(self.name))
Traceback (most recent call last):
File “c:\0.ITstudy\final_project\YOLO_v3_tutorial_from_scratch-master\video.py”, line 156, in
output = model(Variable(img, volatile = True), CUDA)
File “C:\Users\Playdata\Anaconda3\lib\site-packages\torch\nn\modules\module.py”, line 489, in call
result = self.forward(*input, **kwargs)
File “c:\0.ITstudy\final_project\YOLO_v3_tutorial_from_scratch-master\darknet.py”, line 200, in forward
x = torch.cat((map1, map2), 1)
RuntimeError: invalid argument 0: Sizes of tensors must match except in dimension 1. Got 76 and 152 in dimension 2 at c:\a\w\1\s\tmp_conda_3.7_070024\conda\conda-bld\pytorch-cpu_1544079887239\work\aten\src\th\generic/THTensorMoreMath.cpp:1333

Anyone who can help me to solve the issue?

So far, I’ve trained customized dataset, using darknet.
I edited some lines within yolov3.cfg file to train the dataset.

Width = 416 to 608 at 8th line.

Height=416 to 608 at 9th line.

and then
stride 2 to 4 at 717th line.

route layers -1,36 to -1, 11 at 720 line.

I’m new user of pytorh forum. therfore I could put only 2 link… sorry :frowning:

I have solved this issue!!