Installation error rleated to Pytorch

i have been trying to install the fastai library using pip install git+ . The installation process gave the following error messages. Even I tried to install torch first, and then run the above git command again, the same error messages still appear. How to solve this problem. Thanks.

Collecting torch<0.4 (from fastai)
  Using cached
    Complete output from command python egg_info:
    Traceback (most recent call last):
      File "<string>", line 1, in <module>
      File "C:\Users\shuxi\AppData\Local\Temp\pip-install-oe2ba4vx\torch\", line 11, in <module>
        raise RuntimeError(README)
    RuntimeError: PyTorch does not currently provide packages for PyPI (see status at

    Please follow the instructions at to install with miniconda instead.

Command "python egg_info" failed with error code 1 in C:\Users\shuxi\AppData\Local\Temp\pip-install-oe2ba4vx\torch\

I’m not familiar with the fastai installation, but somehow PyTorch 0.1.2 is cached and being used.
Could you try to ignore the cache with:

pip install git+ --no-cache-dir

I am also encountering same issue. --no-cache-dir did not solved my problem. Do you have any other suggestion?

As I’m really not familiar with the fastai wrapper, maybe @jphoward might give you some advice.

Thank you for quick response. I hope @jphoward may find some time for this.