Installing Pytorch

So i’m really new to Pytorch, and I’ve been having issues with installing pytorch nonstop. It keeps telling me that it couldn’t find a version that satisified the requirement torch, if anyone has any idea to fix, feel free to dm me on discord Joycebartfrank#3470

@frankvanpaassen Maybe you are trying to installing a Pytorch version that doesn’t exist for example You can check Previous PyTorch Versions | PyTorch for list of all pytorch versions and respective torchtext and torchvision libaries.

When I type pip install pytorch, i dont specific a version, so I can’t imagine that the version would be the issue…

pip install pytorch is wrong, so copy/paste the commands from the install instructions e.g.:

pip3 install torch torchvision torchaudio
# or 
pip3 install torch==1.10.2+cu113 torchvision==0.11.3+cu113 torchaudio==0.10.2+cu113 -f
1 Like

See i did that, then it gives me errors again, first it gives me a warning saying that there is a missing-index-doctype, then it tells me there is a problematic url, and that it is unable to find a version that satisifies the requirement torch=1.10.2+cu113

Maybe you would need to update pip or are using an unsupported Python version?
The cmd works for me:

pip install torch==1.10.2+cu113 -f
Looking in links:
Collecting torch==1.10.2+cu113
  Downloading (1821.4 MB)
     ━━━━━━━━╸━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 0.4/1.8 GB 10.8 MB/s eta 0:02:13

pip install torch==1.10.2+cu113 -f
Looking in links:
warning: missing-index-doctype

× The package index page being used does not have a proper HTML doctype declaration.
╰─> Problematic URL: (the pytorch one)

note: This is an issue with the page at the URL mentioned above.
hint: You might need to reach out to the owner of that package index, to get this fixed. See github\pypa/pip/issues/10825 for context.
ERROR: Could not find a version that satisfies the requirement torch==1.10.2+cu113 (from versions: none)
ERROR: No matching distribution found for torch==1.10.2+cu113

This was the error I just got with that same command, my pip is updated, and I have the most recent version of Python, and ideas? Btw, I slightly changed the links in this comment due to restrictions from pytorch forums for me, however I assure you they were the same links as you gave me.

Were you able to check your Python version and verify that the pip wheels are actually built for it?

how do I verify that?? If you can please give me steps that would be awesome!

Just run python in your terminal and check the Pyhton version:

Python 3.8.12 | packaged by conda-forge | (default, Oct 12 2021, 21:59:51) 
[GCC 9.4.0] on linux

Alternatively, python --version would also work.
Make sure you are using 3.6 to 3.9.

EDIT: small correction: even though the Python 3.6 wheels are built, I would recommend to update as Python 3.6’s EOL is reached as of Dec 2021.

my python version is 3.10.2, do i have do downgrade?

Yes, you would have to downgrade to 3.9 or try to build from source (if 3.10 is fully supported by now).

how would i go about downgrading? do i just install python 3.9 and that’s it? and then just add to path?
edit: Thank you so much, after having downgraded python it worked, if only I knew before, but thank you so much man… real lifesaver.