Is GLIBC2.17 version really required

Do we really need both glibc2.14 and glibc2.17 to import torch in python.
If I cannot upgrade glibc2.17 is there some other alternate?
Config: anaconda2, cuda 8.0, pytorch .4


PyTorch is built on CentOS-7, which has glibc: 2.17. Hence, you need a maching that has glibc >= 2.17 to work.

Here’s a list of Linux distros and their glibc versions: