Kernel dies when I try to use torch on jupyter notebook

Please help me I have tried everything. I have tried to downgrade torch. This happens every time I try to run my code:

You probably want to clarify what your code is doing. I assume the kernel does not idea from simply running import torch

When one of my kernels dies, then it’s usually always because of running out memory. Are you trying to load huge chunks of date all at once?

It dies just by running these imports:

from skimage import color, io, measure, img_as_ubyte, draw
from skimage.measure import profile_line
from skimage.transform import rescale, resize
import matplotlib.pyplot as plt
import numpy as np
import pydicom as dicom
from os import listdir
from os.path import isfile, join
from skimage.filters import prewitt_h
from skimage.filters import prewitt_v
from skimage.filters import prewitt
from skimage.filters import median
from skimage.filters import gaussian
from import Dataset
import nltk
import torch
import torch.nn as nn
#import torchvision.transforms.functional as TF

Did you try each imports individually to see which fails, or do all fail. If the latter, is would seem to be a bigger issue with your setup/system.