"Model \"XYZ\" has no worker to serve inference request. Please use scale workers API to add workers."

In my config.properties I have “default_workers_per_model=1”.
There is no traffic on this server except for me manually making a single call.

Why is no worker launched/available?

Ah figured out the issue

WARNING: The directory '/app/.cache/pip' or its parent directory is not owned or is not writable by the current user. The cache has been disabled. Check the permissions and owner of that directory. If executing pip with sudo, you should use sudo's -H flag.ERROR: Could not install packages due to an OSError: [Errno 28] No space left on device: '/tmp/pip-target-ipboar3k/lib/python/cmake/data/share/cmake-3.26/Help/prop_tgt/VS_DOTNET_REFERENCES.rst'

Obviously a bit misleading error message.