Not a supported wheel on this platform

I tried installing pytorch in my pc which has Debian. I get error stating that it is not a supported wheel on this platform both for with and without UCS2 versions of python 2.7

torch-0.2.0.post2-cp27-cp27m-manylinux1_x86_64.whl is not a supported wheel on this platform.
torch-0.2.0.post2-cp27-cp27mu-manylinux1_x86_64.whl is not a supported wheel on this platform.


$uname -a
Linux senior 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt25-2+deb8u3 (2016-07-02) x86_64 GNU/Linux

$lsb_release -a
No LSB modules are available.
Distributor ID:	Debian  
Description:	Debian GNU/Linux 8.5 (jessie)
Release:	8.5
Codename:	jessie

$python --version
Python 2.7.9

pip --version

That will reveal which version of python your pip is associated with, and then it’ll be easier to figure out the problem.

pip 1.5.6 from /usr/lib/python2.7/dist-packages (python 2.7)

that’s really weird. from what you’ve shown so far, one of those wheels has to work.

ya it is indeed weird. I am able to install it in my laptop. Just doesn’t seem to work on my pc…

It is interesting to note that the below command worked:

pip install --user https://s3.amazonaws.com/pytorch/whl/cu75/torch-0.1.6.post22-cp27-none-linux_x86_64.whl

This is an older version though. I found this answer from one of your comments which actually solved the problem back in January for some other user. I can download this version. But if there is a fix I would obviously would love to install the latest version.

the obvious but hacky fix is to rename the file torch-0.2.0.post2-cp27-cp27mu-manylinux1_x86_64.whl to torch-0.2.0.post2-cp27-cp27mu-none_x86_64.whl

Stuck at same place. Wheel is not supported, while I’m using Linux Mint (Ubuntu 16.04) with Python 2.7

does not work for me

I provided full instructions here:

@shehzikhan what’s the output of pip --version?

Hi.

changing to none for whl file didn’t work.

What did work was building from source. Also had to set environment variable No_Cuda to true. Just an information to pass on to others.