Old version of pytorch (v0.1.12) with CUDA 10.1


I need to use an old version of pytorch (0.1.12) for running an author’s implementation. Can I install it from source with CUDA 10.1?

I cloned the pytorch repository, and checked out v0.1.12. I then ran the following

conda install numpy pyyaml mkl setuptools cmake gcc cffi

where I got an error saying that package ‘gcc’ wasn’t found.

I tried ignoring this and running the following

conda install numpy pyyaml mkl setuptools cmake cffi
conda install -c pytorch magma-cuda100

export CMAKE_PREFIX_PATH=~/anaconda3/
python setup.py install

But this installs pytorch without CUDA/CUDnn. What can I do to install pytorch v0.1.12 with my current version of CUDA (which is on a server where I do not have root access)?

Any help would be appreciated. Thanks.


Have you tried installing the cuda packages in conda? That should make sure that it is detected during installation from source.

Hi, thanks for the response.
I later just tried to compile it with an older version of CUDA (7.5). Realized I needed to install just the CUDA toolkit at a non-root location and it works with the Nvidia driver I have (418.67). Haven’t tried it with cuda 10.1 toolkit yet, but for now, I can just run with the cuda7.5

1 Like