Projector tab doesn't appear

Hi, I’ve been following the tutorial for Visalizing models, data, and training with Tensorboard and got stuck at section 4 of the tutorial - Adding a “Projector” to TensorBoard.

After I run the code and refresh the Tensorboard page at http://localhost:6006/ , a Projector tab doesn’t appear. When I choose Projector from the drop down menu on the right side, I get an empty page. Then, in the cmd window I get the following error:

TensorFlow installation not found - running with reduced feature set.
Serving TensorBoard on localhost; to expose to the network, use a proxy or pass --bind_all
TensorBoard 2.0.0 at http://localhost:6006/ (Press CTRL+C to quit)
Exception in thread ProjectorPluginIsActiveThread:
Traceback (most recent call last):
  File "C:\Users\theto\Miniconda3\envs\pytorch\lib\threading.py", line 926, in _bootstrap_inner
    self.run()
  File "C:\Users\theto\Miniconda3\envs\pytorch\lib\threading.py", line 870, in run
    self._target(*self._args, **self._kwargs)
  File "C:\Users\theto\Miniconda3\envs\pytorch\lib\site-packages\tensorboard\plugins\projector\projector_plugin.py", line 322, in _determine_is_active
    if self.configs:
  File "C:\Users\theto\Miniconda3\envs\pytorch\lib\site-packages\tensorboard\plugins\projector\projector_plugin.py", line 340, in configs
    self._augment_configs_with_checkpoint_info()
  File "C:\Users\theto\Miniconda3\envs\pytorch\lib\site-packages\tensorboard\plugins\projector\projector_plugin.py", line 362, in _augment_configs_with_checkpoint_info
    tensor = _read_tensor_tsv_file(fpath)
  File "C:\Users\theto\Miniconda3\envs\pytorch\lib\site-packages\tensorboard\plugins\projector\projector_plugin.py", line 157, in _read_tensor_tsv_file
    return np.array(tensor, dtype='float32')
ValueError: setting an array element with a sequence.

I’m running Pytorch 1.3.1 with Tensorboard 2.0.0 in a conda environment.

Any idea why this is happening?

1 Like

Same here the Projector Tab does not appear, but I can choose it from the drop down menu and seems to be working from there.

I got the same problem, anyone managed to solve this?

EDIT: Using Pytorch 1.4.0 and installing tensorboard nightly (2.3.0a I believe I installed) then it worked perfectly for me. Might be worth checking if you run into the same issue.

1 Like

I have this problem too.
My solution is to install tensorflow as backend support.

I had this problem as well, and the solution is to restart tensorboard in the terminal