PyTorch 1.3 wheels for Raspberry Pi (Python 3.7)

I’ve made it available here: https://wintics-opensource.s3.eu-west-3.amazonaws.com/torch-1.3.0a0%2Bdeadc27-cp37-cp37m-linux_armv7l.whl.

Have fun !

6 Likes

it’s works, thanks you

It works! Thank you :slight_smile:

I run pip3 install *.whl of your wheels ,but when I import torch in my code,it says ImportError: No module named torch

How Can I solve this problem?

Oh I should run python3 thanks it works

Torch 1.4 wheels available here -> Installing pytorch on raspberry pi 3 !

Hi, do you have wheels for Python 3.8 or could you explain me how you compiled it?

I’m using a Rockchip processor with Manjaro. PyTorch doesn’t compile for me and it is really a pain to downgrade to python 3.7.

For the moment, I don’t have access to the RPI where I’ve made the source code modifications (I’m under lockdown and far from my office). But as far as I can remember, I just changed the commit of third_party/protobuf to something more recent. I did this because I noticed an error coming from atomic types, and I saw an issue in the protobuf repo (I can’t remember which one) related to the same kind of problem. So naturally I hooked PyTorch source code to a commit fixing the issue.

Just to make things clear, I don’t suffer from any kind of memory loss desease (at least I can’t remember being diagnosed with it :smile:). If I don’t remember anything it is because I actually did it in September 2019 (for compiling torch 1.3), and I just kind of did the same steps some weeks ago without thinking too much, and it just worked.

BTW, the binaries generated by my compilation aren’t perfect, for instance, quantization isn’t working. But the main torch functionalities are working just fine, so I think it is useful making the binaries available for everyone to use.