is avalaible false nvidia-sim not recognized


I want to use pytorch but I get pytorch.cud is.avalaible FALSE. I tried to install CUDA but I don’t think/know if it worked.

Here are my configuration:
Python 3.7.3
Nvidia Getforce GTX 960M
I am using pip.

Here is what I did.
I installed Visual Studio 2019. I installed CUDA Toolkit 10.2 Download (but I am not sure it worked though) using the following link:

When I run on my command, I get:
(python) torch.cuda.is_available()

  • (python) torch.backends.cudnn.enabled
  • (cmd) nvidia-smi
    nvidia not defined
  • (cmd) nvcc --version
    nvcc not defined

I looked up many wepages but I didn’t find something to solve my problem. Do you think I should use Anaconda instead of pip? Can it be a matter of path?

Thanks a lot for your patience.

What is the output of "C:\Program Files\NVIDIA Corporation\NVSMI\nvidia-smi.exe" in CMD?

Thank you for your answer. It says it is not recognized as an intern command (in French).

So looks like you don’t have the GPU driver installed.