Pytorch installation keeps failing

I have ubuntu 14.0.4 ,using a virtualenv,python 3.4.3 and trying to install pytorch every way possible with only frustration.

I tried

raise RuntimeError(README)

RuntimeError: PyTorch does not currently provide packages for PyPI ().

Please follow the instructions at to install with miniconda instead.

tried pip3 install
pip3 install torchvision
(as recommended by website)

torch-0.3.1-cp35-cp35m-linux_x86_64.whl is not a supported wheel on this platform.

I dont understand why is Python3.4.3 not supported for pytorch!
pip3 --version
pip 9.0.1 from /home/*/*lib/python3.4/site-packages (python 3.4)

Since you’re using a virtualenv anyways, is it possible to install python 3.5, 3.6, or 2.7 and then repeat the installation process?

Hi @richard… Thanks that is how I ended up resolving the issue.
But it is useful to know that pytorch has this kind of hard minimum requirement of Python 3.5. I could not find a single document which said that. So for all who is wasting time trying to resolve this this could be useful to know that. Just use python 3.5+