PyTorch installation problems with stable, windows, pip, python and cpu


I have been struggling with the installation of PyTorch on my windows 10 laptop for quite a while. After selecting the appropriate entry in the installation matrix: stable(1.10), windows, pip, Python, cpu, I have got the recomended command: pip3 install torch torchvision torchaudio.
Running this command in DOS mode without administrator rights gives the following error message:
ERROR: Could not find a version that satisfies the requirement torch (from versions: none)
ERROR: no matching distribution found for torch

I have tried older versions such as:
pip install torch==1.4.0+cpu torchvision==0.5.0+cpu -f with similar error message.

What can I do?

Ivo van Baren

Further information:
I have re-installed Python to the latest version:
Python 3.10.1 (tags/v3.10.1:2cd268a, Dec 6 2021, 19:10:37) [MSC v.1929 64 bit (AMD64)] on win32

The Python libraries are:
Package Version

colorama 0.4.4
cycler 0.11.0
fonttools 4.28.2
fvcore 0.1.5.post20211023
iopath 0.1.9
kiwisolver 1.3.2
matplotlib 3.5.0
numpy 1.21.4
packaging 21.3
parameterized 0.8.1
Pillow 8.4.0
pip 21.3.1
portalocker 2.3.2
pyparsing 3.0.6
python-dateutil 2.8.2
PyWavelets 1.2.0
pywin32 302
PyYAML 6.0
scipy 1.7.3
setuptools 58.1.0
setuptools-scm 6.3.2
six 1.16.0
tabulate 0.8.9
termcolor 1.1.0
tomli 1.2.2
tqdm 4.62.3
wheel 0.37.0
yacs 0.1.8

System Info
|Processor|Intel(R) Core™ i5-4200M CPU @ 2.50GHz 2.50 GHz|
|Geïnstalleerd RAM-geheugen|8,00 GB|
|Type systeem|64-bits besturingssysteem, x64-processor|

Operating system:

Editie Windows 10 Home
Versie 21H1
Installatiedatum ‎13-‎8-‎2020
Build van besturingssysteem 19043.1348
Ervaring Windows Feature Experience Pack 120.2212.3920.0


I have the exact same problem with similar configuration. I’ve been looking everywhere for a way to download torch. I’m completely lost. Please help



Besides the above problem with PyTorch, I have the same problem when installing TensorFlow.: `
“pip install tensorflow” gives exactly the same error message. Also pip3 doesn’t work. Is there something wrong with pip?.


If I’m not mistaken, Python 3.10 is not (yet fully) supported, so you might need to downgrade to 3.9 for now.

i could not install pytorch or torch module .i am using python 3.8 now. i am stuck here to implement this code an d need result’s immediately . can you provide some help.