PyTorch Is not installing PIP - latest version

Here is the Pip command I used. I got it from the official website (Start Locally | PyTorch)

pip3 install torch==1.10.1+cu102 torchvision==0.11.2+cu102 torchaudio===0.10.1+cu102 -f https://download.pytorch.org/whl/cu102/torch_stable.html

The Error

ERROR: Could not find a version that satisfies the requirement torch==1.10.1+cu102 (from versions: none)
ERROR: No matching distribution found for torch==1.10.1+cu102

I think I know why the installation is not working.

The Pip command is trying to install a Module from the website listings (https://download.pytorch.org/whl/cu102/torch_stable.html)
The Modules pip is trying to install are

torch==1.10.1+cu102
torchvision==0.11.2+cu102
torchaudio===0.10.1+cu102

the Modules are Non-existing, not on the list that is why the errors happened.

the Owners need to update this problem

The pip wheels exist at the linked location (e.g. here is the Python3.9 pip wheel for Linux) and your posted command also works fine for me:

pip install torch==1.10.1+cu102 torchvision==0.11.2+cu102 torchaudio===0.10.1+cu102 -f https://download.pytorch.org/whl/cu102/torch_stable.html
Looking in links: https://download.pytorch.org/whl/cu102/torch_stable.html
Collecting torch==1.10.1+cu102
  Downloading https://download.pytorch.org/whl/cu102/torch-1.10.1%2Bcu102-cp38-cp38-linux_x86_64.whl (881.9 MB)
     |████████████████████████████████| 881.9 MB 34 kB/s              
Collecting torchvision==0.11.2+cu102
  Downloading https://download.pytorch.org/whl/cu102/torchvision-0.11.2%2Bcu102-cp38-cp38-linux_x86_64.whl (23.2 MB)
     |████████████████████████████████| 23.2 MB 12.5 MB/s            
Collecting torchaudio===0.10.1+cu102
  Downloading https://download.pytorch.org/whl/cu102/torchaudio-0.10.1%2Bcu102-cp38-cp38-linux_x86_64.whl (2.9 MB)
     |████████████████████████████████| 2.9 MB 14.4 MB/s            
Requirement already satisfied: typing-extensions in ./miniforge3/envs/tmp/lib/python3.8/site-packages (from torch==1.10.1+cu102) (4.0.0)
Collecting pillow!=8.3.0,>=5.3.0
  Using cached Pillow-8.4.0-cp38-cp38-manylinux_2_17_x86_64.manylinux2014_x86_64.whl (3.1 MB)
Collecting numpy
  Using cached numpy-1.21.5-cp38-cp38-manylinux_2_12_x86_64.manylinux2010_x86_64.whl (15.7 MB)
Installing collected packages: torch, pillow, numpy, torchvision, torchaudio
  Attempting uninstall: torch
    Found existing installation: torch 1.10.0
    Uninstalling torch-1.10.0:
      Successfully uninstalled torch-1.10.0
  Attempting uninstall: torchaudio
    Found existing installation: torchaudio 0.10.0
    Uninstalling torchaudio-0.10.0:
      Successfully uninstalled torchaudio-0.10.0
Successfully installed numpy-1.21.5 pillow-8.4.0 torch-1.10.1+cu102 torchaudio-0.10.1+cu102 torchvision-0.11.2+cu102

I don’t know if you might be facing a Python version mismatch (supported versions are 3.6-3.9), are using a 32bit Python installation, or outdated pip versions, which can’t find the wheels.

I am on Windows 10
and i am using

Python 3.10
Pip (21.3.1)

You would need to use an older Python version, as 3.10 is not supported yet.

Thank you.

is it possible you can write on the website what version of python is needed for each pyTorch version?

This might be possible, so feel free to create a feature request on GitHub. :slight_smile:
Currently the install instructions mention:

It is recommended that you use Python 3.6, 3.7 or 3.8, which can be installed via any of the mechanisms above .

and I’m mostly using 3.8, so unsure if 3.9 has any (known) issues.