Pytorch tensorboard trying to use CUDA 9.0 instead of 10.1

I’m using pytorch 1.4 on Ubuntu 18.04LTS and python 3.6.8. When trying to invoke tensorboard from the terminal I always get the following error:

Traceback (most recent call last):
  File "/usr/bin/tensorboard", line 7, in <module>
    from tensorboard.main import run_main
  File "/usr/lib/python2.7/site-packages/tensorboard/", line 39, in <module>
    from tensorboard import default
  File "/usr/lib/python2.7/site-packages/tensorboard/", line 34, in <module>
    import tensorflow as tf
  File "/usr/lib/python2.7/site-packages/tensorflow/", line 22, in <module>
    from tensorflow.python import pywrap_tensorflow  # pylint: disable=unused-import
  File "/usr/lib/python2.7/site-packages/tensorflow/python/", line 49, in <module>
    from tensorflow.python import pywrap_tensorflow
  File "/usr/lib/python2.7/site-packages/tensorflow/python/", line 74, in <module>
    raise ImportError(msg)
ImportError: Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/tensorflow/python/", line 58, in <module>
    from tensorflow.python.pywrap_tensorflow_internal import *
  File "/usr/lib/python2.7/site-packages/tensorflow/python/", line 28, in <module>
    _pywrap_tensorflow_internal = swig_import_helper()
  File "/usr/lib/python2.7/site-packages/tensorflow/python/", line 24, in swig_import_helper
    _mod = imp.load_module('_pywrap_tensorflow_internal', fp, pathname, description)
ImportError: cannot open shared object file: No such file or directory

It looks like it expects to CUDA 9.0 version instead of 10.X how can this be solved?
I have CUDA 10.2 installed.
BTW the log dir is created and it’s not empty

It looks like Tensorflow is called internally and tried to open libcublas.
Do you have a TF installation on your system or how did you install tensorboard?
If you are using the one shipped in PyTorch, tensorflow shouldn’t be called.

Problem solved :slight_smile:
I have downgraded tensorboard and installed it using conda.
Thank you Patrick