Segmentation fault error of load data with old pytorch versions

Hello :slight_smile:

I have Cuda version 10.0 and I can’t upgrade to upper versions (I have no administrator access).

Torch versions (1.2.0, 1.3.0, 1.3.1, and 1.4.0) gives me a segmentation fault error when load data. The possible solution is to update Pytorch to 1.5.0 but I can’t because of my Cuda version 10.0.

When I tried to install Pytorch using pip I got an error of ‘OSError: /lib64/ version `GLIBC_2.18’ not found (required by /lib64/’.

I have tried to install Pytorch 1.5.0 and I get AssertionError: Torch not compiled with CUDA enabled

My questions are:

  1. Is there any way to fix the segmentation fault issue with versions below 1.4.0?
  2. Why I get a version GLIBC_2.18’ not found error when I usepip` to install Pytorch?

Kind regards,

Any suggestions to fix this issue?

Kind regards

Your local CUDA toolkit won’t be used, if you install the conda binaries or pip wheels, as they ship with their own CUDA runtime. You would only need to install the appropriate NVIDIA driver.
However, your local CUDA installation will be used if you build PyTorch from source or build custom CUDA extensions.

I would not recommend to try to isolate the seg fault, as it might have been a known issue which was already fixed.

For the GLIBC issue: could you create a new virtual environment and try to install the binaries again?

1 Like

Thank you sir for your valuable comment.

I have installed Pytorch from source with a virtual environment as follow:

pip install torch==1.3.1+cu100 torchvision==0.4.2+cu100 -f

There is no GLIBC issue but still getting a segmentation fault error.

An image is attached.

System information:

Could you explain this?

Install the latest stable version (1.7.0) or the nightly binaries, please, since this error might have already been solved.

1 Like