Session crashed for an unknown reason

Hi, hope you’re doing well.
Although I updated my torch version and cuda by

!pip install -q torch-scatter -f
!pip install -q torch-sparse -f
!pip install torch-geometric

, my session crashed when I import torch_geometric.

Would u please help me? where is the problem?

Try to rerun the import statement from your terminal with gdb and post the stacktrace here:

gdb --args python

excuse me, I did not understand what do you mean by

gdb --args python



If you have time, would u please explain it a bit?

These are commands that you should execute in your (Linux) terminal to create the backtrace of the crash in your application.

Thanks, my problem is solved

What was the issue and how did you solve it?

To be honest, I don’t know where the problem was…

I opened a new notebook and copied all the things from the previous notebook into the new one and I saw it worked correctly in the new notebook…
So I decided to close my google colab for 1 hour. After that I ran my previous notebook and I saw it works well even in it.
I really don’t know what had happened, not to mention, that I restarted the run time and even closed the google colab many times, but it didn’t work well, surprisingly, it worked well after 1 hour that I had closed my google colab. It’s a bit strange.

I wanna say how to find my problem, I’ve just found it.
I’ve used !pip uninstall torch scatter and !pip uninstall torch sparse
and then install pytorch geometric, this time it works well.