Sign in and Log in not working properly

I tried signing up with github, facebook and gmail account. The site should either end up logging me in or allow me to login with the same accounts. But it doesn’t work.

Only filling up the data fields work for signing up.

Could you give an example, what’s not working and how you solved it?
Did the GitHub/FB/… account login not work at all and did you get any error message?

Ohh yes… Github login tries to ask for permission which I granted. Then I get redirected back to this site where I’m still not logged in.
Google tries to log me in asks which google account to log in with. I get the same result as github once I choose the account.
At this point I tried logging in with the datafields where the fields say that all the supplied values seem valid. But when I click sign-up, I get an error saying “email id or username or password is wrong”
Facebook straight up gave me an error so I knew it didn’t work. But once I’m redirected to facebook I can’t press the back button to come back here for some reason.

As a list ditch attempt filling up the data fields with one of my gmail accounts worked.