Tensorboard logging correctly but not displaying on localhost

I am following the tutorial Visualizing Models, Data, and Training with TensorBoard, but cannot get TensorBoard to display on my localhost (getting a blank screen). Based on the warnings reported to the console (shown below), it appears this is a problem not with SummaryWriter but with the TensorBoard machinery creating the localhost.

I am running my code on a virtual environment through PyCharm equipped with Python 3.7, Torch 1.4.0, and TensorBoard 2.1.0. I also downloaded TensorFlow and TensorFlow GPU 2.1.0 just in case. I have CUDA 10.0 installed.

My code (identical to tutorial, but placed in main block due to issues with num_workers):

import matplotlib.pyplot as plt
import numpy as np
import torch
import torchvision
import torchvision.transforms as transforms
import torch.nn as nn
import torch.nn.functional as F
import torch.optim as optim
from torch.utils.tensorboard import SummaryWriter

def main():
    # transforms
    transform = transforms.Compose(
        transforms.Normalize((0.5,), (0.5,))])

    # datasets
    trainset = torchvision.datasets.FashionMNIST('./data',
    testset = torchvision.datasets.FashionMNIST('./data',

    # dataloaders
    trainloader = torch.utils.data.DataLoader(trainset, batch_size=4,
                                            shuffle=True, num_workers=2)

    testloader = torch.utils.data.DataLoader(testset, batch_size=4,
                                            shuffle=False, num_workers=2)

    # constant for classes
    classes = ('T-shirt/top', 'Trouser', 'Pullover', 'Dress', 'Coat',
            'Sandal', 'Shirt', 'Sneaker', 'Bag', 'Ankle Boot')

    net = Net()
    criterion = nn.CrossEntropyLoss()
    optimizer = optim.SGD(net.parameters(), lr=0.001, momentum=0.9)

    # default `log_dir` is "runs" - we'll be more specific here
    writer = SummaryWriter('runs/fashion_mnist_experiment_1')

    # get some random training images
    dataiter = iter(trainloader)
    images, labels = dataiter.next()

    # create grid of images
    img_grid = torchvision.utils.make_grid(images)

    # show images
    matplotlib_imshow(img_grid, one_channel=True)

    # write to tensorboard
    writer.add_image('four_fashion_mnist_images', img_grid)

# helper function to show an image
# (used in the `plot_classes_preds` function below)
def matplotlib_imshow(img, one_channel=False):
    if one_channel:
        img = img.mean(dim=0)
    img = img / 2 + 0.5     # unnormalize
    npimg = img.numpy()
    if one_channel:
        plt.imshow(npimg, cmap="Greys")
        plt.imshow(np.transpose(npimg, (1, 2, 0)))

class Net(nn.Module):
    def __init__(self):
        super(Net, self).__init__()
        self.conv1 = nn.Conv2d(1, 6, 5)
        self.pool = nn.MaxPool2d(2, 2)
        self.conv2 = nn.Conv2d(6, 16, 5)
        self.fc1 = nn.Linear(16 * 4 * 4, 120)
        self.fc2 = nn.Linear(120, 84)
        self.fc3 = nn.Linear(84, 10)

    def forward(self, x):
        x = self.pool(F.relu(self.conv1(x)))
        x = self.pool(F.relu(self.conv2(x)))
        x = x.view(-1, 16 * 4 * 4)
        x = F.relu(self.fc1(x))
        x = F.relu(self.fc2(x))
        x = self.fc3(x)
        return x

if __name__ == '__main__':


(venv) C:\Users\xande\OneDrive - Personal\Documents\Information Pollution>python TensorboardTest.py
2020-01-26 10:57:58.935034: I tensorflow/stream_executor/platform/default/dso_loader.cc:44] Successfully opened dynamic library cudart64_101.dll

(venv) C:\Users\xande\OneDrive - Personal\Documents\Information Pollution>tensorboard --logdir=runs
2020-01-26 10:58:36.091352: W tensorflow/stream_executor/platform/default/dso_loader.cc:55] Could not load dynamic library 'cudart64_101.dll'; dlerror: cudart64_101.dll not found
2020-01-26 10:58:36.099596: I tensorflow/stream_executor/cuda/cudart_stub.cc:29] Ignore above cudart dlerror if you do not have a GPU set up on your machine.
Serving TensorBoard on localhost; to expose to the network, use a proxy or pass --bind_all
TensorBoard 2.1.0 at http://localhost:6006/ (Press CTRL+C to quit)

Localhost after running these commands (in Chrome, but also tried in other browsers):

Especially puzzling is the fact that my code seems to be able to open cudart64_101.dll, but the tensorboard call cannot. This seems like it’s likely the issue, but I am not even sure why my GPU should be involved at all right now, so I am stuck.

Any help would be appreciated!

I am facing the same issue. Any help?

Hello Guys,

I an facing the same issue. Could you suggest any remarks.

Any help is appreciated.

I have same problem , I Install TensorBoard version 1.15.0 and my problem solved