The issue of using torch::upsample in C++ while using the libtorch

hello everyone, recently I’m using the libtorch to coding my CNN model on C++. I have met a problem which you can see from the figure1.

the code has pasted below’

at::Tensor test = torch::rand({1,1,2, 10 }).to(torch::kCUDA);

std::cout << test << std::endl;

//torch::upsample_nearest1d(test, { 20 });

torch::upsample_bilinear2d(test, {1,1,2,20 }, true);//this line cause that problem

I have tried another functions such as maxpool, convolution, they all worked well. however all upsampling function will break down. I have no idea about how to solve this problem

Visual Studio 2015
CUDA 10.0
libtorch nightly version

Do you have the backtrace for this error?

thanks for your attention,I have done this bug, the error cause by the coding, the right way to call the function is this way:
std::cout << test << std::endl;

//torch::upsample_nearest1d(test, { 20 });

std::cout << torch::upsample_bilinear2d(test, { 2,20 }, true) << std::endl;