Torch.cuda.is_available() Keeps returning false

I am trying to run stylegan3 repo, but I can´t figure out why pytorch keeps returning false when doing torch.cuda.is_available(). My graphics card is supported for CUDA 11.3. Also, print(torch.version.cuda) is returning “Unable to initialize device PRN”.

I have tried many times to reinstall torch using conda, (and also tried installing it with pip, but always getting an error when doing so)

Here´s all I know:

OS: Windows 10
Graphics Card: GTX 970
GPU driver version: image (496.13)
Installed CUDA version: 11.3

running nvcc --version I get:

nvcc: NVIDIA (R) Cuda compiler driver
Copyright (c) 2005-2021 NVIDIA Corporation
Built on Sun_Mar_21_19:24:09_Pacific_Daylight_Time_2021
Cuda compilation tools, release 11.3, V11.3.58
Build cuda_11.3.r11.3/compiler.29745058_0

running nvidia-smi returns CUDA Version 11.5 (weirdly enough. I had uninstalled 11.5, and I double checked it was uninstalled, and the version I do have is 11.3):
| NVIDIA-SMI 496.13 Driver Version: 496.13 CUDA Version: 11.5 |
| GPU Name TCC/WDDM | Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
| | | MIG M. |
| 0 NVIDIA GeForce … WDDM | 00000000:01:00.0 On | N/A |
| 0% 59C P5 19W / 200W | 1009MiB / 4096MiB | 4% Default |
| | | N/A |

You’ve most likely installed the CPU-only binaries, which should have been shown in during the installation. I know that the current 1.10 release has issues finding torchtext+cu113 so you might want to install the nightlies or skip torchtext, if not needed.

I’ve installed GPU version. But in virtual environment I get False, but in Base environment it shows True. My python version is 3.80

Most likely your environments have multiple installations available, so make sure to use the desired one only. If you have trouble, create a new env and install the GPU version there.