Torchaudio breaks 1.10.0.dev20210624 nightly-build install (conda on linux)

Hi Forum!

An attempt to install today’s (6/24/21) nightly build failed. I am using
conda on linux.

The attempt produced a bunch of package conflicts, but torchaudio
seemed to be part of the problem. I then tried installing without
torchaudio and it mostly worked, but numpy was missing. After
installing numpy by hand (with conda), things appear okay (but
without torchaudio.)

Here are the two reported torchaudio conflicts:

torchaudio -> python[version='>=3.9,<3.10.0a0'] -> libstdcxx-ng[version='>=7.2.0|>=7.3.0|>=7.5.0'
torchaudio -> pytorch==1.10.0.dev20210618

I attempted the install on a newly-created and cleaned conda

Here is the install command that failed:

(nightly) user@server:~$ conda install pytorch torchvision torchaudio cudatoolkit=10.2 -c pytorch-nightly

and the install command that succeeded:

(nightly) user@server:~$ conda install pytorch torchvision cudatoolkit=10.2 -c pytorch-nightly

Here is the numpy error (before installing numpy by hand) when
running the newly-installed nightly build without torchaudio:

>>> import torch
/home/user/miniconda3/envs/nightly/lib/python3.9/site-packages/torch/package/ UserWarning: Failed to initialize NumPy: No module named 'numpy' (Triggered internally at  /opt/conda/conda-bld/pytorch_1624518427672/work/torch/csrc/utils/tensor_numpy.cpp:68.)
  _dtype_to_storage = {data_type(0).dtype: data_type for data_type in _storages}
>>> import numpy
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
ModuleNotFoundError: No module named 'numpy'

For completeness, here is the full result of the failed install attempt
that included torchaudio:

user@server:~$ conda create -n nightly
Collecting package metadata (current_repodata.json): done
Solving environment: done

## Package Plan ##

  environment location: /home/user/miniconda3/envs/nightly

Proceed ([y]/n)? y

Preparing transaction: done
Verifying transaction: done
Executing transaction: done
# To activate this environment, use
#     $ conda activate nightly
# To deactivate an active environment, use
#     $ conda deactivate

user@server:~$ conda activate nightly
(nightly) user@server:~$ conda list
# packages in environment at /home/user/miniconda3/envs/nightly:
# Name                    Version                   Build  Channel
(nightly) user@server:~$ conda clean --all
Cache location:
There are no tarballs to remove
WARNING: /home/user/.conda/pkgs does not exist
Cache location:
There are no unused packages to remove
(nightly) user@server:~$ conda install pytorch torchvision torchaudio cudatoolkit=10.2 -c pytorch-nightly
Collecting package metadata (current_repodata.json): done
Solving environment: failed with initial frozen solve. Retrying with flexible solve.
Solving environment: failed with repodata from current_repodata.json, will retry with next repodata source.
Collecting package metadata (repodata.json): done
Solving environment: failed with initial frozen solve. Retrying with flexible solve.
Solving environment: /
Found conflicts! Looking for incompatible packages.                             failed

UnsatisfiableError: The following specifications were found to be incompatible with each other:

Output in format: Requested package -> Available versions

Package libstdcxx-ng conflicts for:
torchvision -> python[version='>=3.9,<3.10.0a0'] -> libstdcxx-ng[version='>=7.2.0|>=7.5.0']
torchvision -> libstdcxx-ng[version='>=5.4.0|>=7.3.0']
pytorch -> libstdcxx-ng[version='>=5.4.0|>=7.3.0']
torchaudio -> python[version='>=3.9,<3.10.0a0'] -> libstdcxx-ng[version='>=7.2.0|>=7.3.0|>=7.5.0']
pytorch -> ninja -> libstdcxx-ng[version='>=7.2.0|>=7.5.0']
cudatoolkit=10.2 -> libstdcxx-ng[version='>=7.3.0']

Package pytorch conflicts for:
torchvision -> pytorch[version='1.1.*|1.10.0.dev20210624|1.9.0.dev20210415|1.9.0.dev20210217|1.8.0.dev20210208|1.8.0.dev20210111|1.7.1.*|1.3.1.*|1.2.0.*|>=0.4|>=0.3']
torchaudio -> pytorch==1.10.0.dev20210618

Package cudatoolkit conflicts for:
torchvision -> pytorch==1.8.0.dev20210208 -> cudatoolkit[version='10.0.*|>=11.0,<11.0.221|9.2.*|>=10.1.243,<10.2.0a0|>=8.0,<8.1.0a0|9.0.*|8.0.*|7.5.*']
pytorch -> cudnn[version='>=7.6,<8.0a0'] -> cudatoolkit[version='>=10.0,<10.1|>=9.0,<9.1']
pytorch -> cudatoolkit[version='10.0.*|>=10.0.130,<10.1.0a0|>=10.1,<10.2|>=10.2,<10.3|>=11.1,<11.2|>=11.2,<11.3|>=11.0,<11.0.221|>=11.0,<11.1|>=9.2,<9.3|>=10.1.243,<10.2.0a0|>=9.2,<9.3.0a0|9.2.*|>=9.0,<9.1.0a0|>=8.0,<8.1.0a0|9.0.*|8.0.*|7.5.*']
torchvision -> cudatoolkit[version='>=10.0.130,<10.1.0a0|>=10.1,<10.2|>=10.2,<10.3|>=11.1,<11.2|>=11.2,<11.3|>=11.0,<11.1|>=9.2,<9.3|>=9.2,<9.3.0a0|>=9.0,<9.1.0a0']

Package cudnn conflicts for:
pytorch -> cudnn[version='5.1.*|6.0.*|>=7.0.0,<=8.0a0|>=7.0.5,<=8.0a0|>=7.1.0,<=8.0a0|>=7.1.3,<8.0a0|>=7.3.0,<=8.0a0|>=7.6,<8.0a0|>=7.6.5,<8.0a0|>=7.6.4,<8.0a0|>=7.3.1,<8.0a0|>=7.1.2,<=8.0a0']
torchvision -> pytorch=1.3.1 -> cudnn[version='6.0.*|>=7.0.0,<=8.0a0|>=7.0.5,<=8.0a0|>=7.1.0,<=8.0a0|>=7.1.3,<8.0a0|>=7.3.0,<=8.0a0|>=7.6,<8.0a0|>=7.6.4,<8.0a0|>=7.3.1,<8.0a0|>=7.6.5,<8.0a0|>=7.1.2,<=8.0a0']


K. Frank

A similar issue is tracked here.
Would you mind adding your problem there (let me know, if I should cross-post it in case you’re not active on GitHub).

I came across the same issue, but I’m told it’s a feature, not a bug (and the error message should be better in the nightlies now) :wink: so it seems you should install it manually.

Hi @ptrblck!

Yes, my install issue does look similar (although not line-by-line

I should also mention that I successfully installed the stable pytorch
(including torchaudio) today without issue. I used this command:

conda install pytorch torchvision torchaudio cudatoolkit=10.2 -c pytorch
>>> torch.__version__

(I didn’t try installing with pip, only conda.)

Please cross-post this for me – I lost github login access when google
fizzled on me somehow.

No worries. Installing numpy manually does seem to work for me.


K. Frank

1 Like