Unable to build Libtorch v1.0.1 from Source

I require libtorch v1.0.1 with cxx11 ABI for a SLAM repo GCNv2_SLAM I am trying to build.
I tried compiling libtorch from source using the v1.0.1 tag but it always ends with the following error
After doing the

git clone -b v1.0.1 https://github.com/pytorch/pytorch.git
git submodule update --init --recursive
mkdir build && cd build
#I am using the following command to build libtorch 
python tools/build_libtorch.py
[ 84%] Linking CXX shared library ../lib/libcaffe2.so
CMakeFiles/caffe2.dir/__/aten/src/ATen/native/cpu/UnaryOpsKernel.cpp.DEFAULT.cpp.DEFAULT.cpp.DEFAULT.cpp.AVX2.cpp.AVX2.cpp.o:(.data.rel.local+0x0): multiple definition of `at::native::DispatchStub<void (*)(at::Tensor&, at::Tensor const&), at::native::truncImpl>::AVX2'
. //similar multiple difinitions errors
CMakeFiles/caffe2.dir/__/aten/src/ATen/native/cpu/Activation.cpp.DEFAULT.cpp.o:(.data.rel.local+0x0): multiple definition of `at::native::DispatchStub<void (*)(at::TensorIterator&, c10::Scalar, c10::Scalar), at::native::threshold_stub>::DEFAULT'
CMakeFiles/caffe2.dir/__/aten/src/ATen/native/cpu/Activation.cpp.DEFAULT.cpp.DEFAULT.cpp.DEFAULT.cpp.DEFAULT.cpp.DEFAULT.cpp.o:(.data.rel.local+0x0): first defined here
collect2: error: ld returned 1 exit status
caffe2/CMakeFiles/caffe2.dir/build.make:109851: recipe for target 'lib/libcaffe2.so' failed
make[2]: *** [lib/libcaffe2.so] Error 1
CMakeFiles/Makefile2:4795: recipe for target 'caffe2/CMakeFiles/caffe2.dir/all' failed
make[1]: *** [caffe2/CMakeFiles/caffe2.dir/all] Error 2
Makefile:140: recipe for target 'all' failed
make: *** [all] Error 2
Traceback (most recent call last):
  File "../tools/build_libtorch.py", line 30, in <module>
    subprocess.check_call(command, universal_newlines=True, env=my_env)
  File "/usr/lib/python3.6/subprocess.py", line 311, in check_call
    raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command '['/home/developer/internship/dev/code/pytorch_cpp/pytorch/tools/build_pytorch_libs.sh', '--use-cuda', '--use-nnpack', '--use-mkldnn', '--use-qnnpack', 'caffe2']' returned non-zero exit status 2.

So I tried to download the precompiled libtorch library. The link on pytorch website doesn’t have the links for LIBTORCH.
I also tried looking at multiple github issues to find the required link but still haven’t been able to find it. Since the authors of the repo have already mentioned not to use the precompiled version of libtorch I am not very hopefull about using it even if i get the link. The earliest version I am able to find is mentioned here in this issue

I have the following system configuration:
CUDA : Cuda compilation tools, release 10.2, V10.2.89
Ubuntu : 18.04
CUDNN : libcudnn8 →

Since I am using cudnn version 8 i have already modified the setup helper python script and CMake files to use cudnn_version.h instead of cudnn.h to get the proper version of CUDNN library
Can anyone please help me with the error in the build?