Unable to install pytorch 1.2.0: EnvironmentError: [Errno 5] Input/output error

don’t bother, it is more likely a filesystem issue: https://github.com/pypa/pip/issues/7032

closing.

hi,
i’ve been trying to install pytorch 1.2.0 on a server using pip install torch torchvision but i’m getting the error:

ERROR: Could not install packages due to an EnvironmentError: [Errno 5] Input/output error.

  • the installation was fine on another server.
  • i tried installing torch using the wheel torch-1.2.0-cp37-cp37m-manylinux1_x86_64.whl, but get the same error.
  • i’m suspecting that there is something going on the failed server. (probably the disc, and the size of the package!)
    installing other packages (on the failed server) is fine.
  • any pointers to the cause? thanks
  • config.:
    • cuda: 10.0
    • ubuntu: 16.04.4

the last lines of the log of pip install torch torchvision: any clues? installing numpy works fine but not torch. it seems something to do with writing rights! or packages using wheels?

ERROR: Could not install packages due to an EnvironmentError.
Traceback (most recent call last):
  File "~/Venvs/test/lib/python3.7/site-packages/pip/_internal/commands/install.py", line 407, in run
    use_user_site=options.use_user_site,
  File "~/Venvs/test/lib/python3.7/site-packages/pip/_internal/req/__init__.py", line 58, in install_given_reqs
    **kwargs
  File "~/Venvs/test/lib/python3.7/site-packages/pip/_internal/req/req_install.py", line 928, in install
    use_user_site=use_user_site, pycompile=pycompile,
  File "~/Venvs/test/lib/python3.7/site-packages/pip/_internal/req/req_install.py", line 461, in move_wheel_files
    warn_script_location=warn_script_location,
  File "~/Venvs/test/lib/python3.7/site-packages/pip/_internal/wheel.py", line 432, in move_wheel_files
    clobber(source, lib_dir, True)
  File "~/Venvs/test/lib/python3.7/site-packages/pip/_internal/wheel.py", line 410, in clobber
    shutil.copyfile(srcfile, destfile)
  File "~/Venvs/test/lib/python3.7/shutil.py", line 122, in copyfile
    copyfileobj(fsrc, fdst)
OSError: [Errno 5] Input/output error

Hi, I met the same problem with you. So, did you solve the problem? If did, could you share it? I would appreciate it very much!

hi,
sorry for late reply.
the problem was solved by the admin.
not sure what they did exactly.
however the source of the issue is the writing on a newly installed disc.
writing large files on it caused i/o error.
this prevented installing new packages including pytorch.

Thank you for your reply. My problem was also solved by the admin.