Unable to replicate model export to C++ with jit.trace. Pytorch 1.0

So, I’m trying to replicate the tutorial found here but it doesn’t seem to work.

Loading the model then passing the model and the example to the trace function works, but when I try to check the output by doing this: out = traced_script_module(torch.ones(1,3,244,244))
it gives me an error incompatible function arguments. The following argument types are supported
Leaving that aside and moving forward with the tutorial, calling save() on traced_script_module also gives an error : AttributeError: ‘function’ object has no attribute 'save’

I’m running Linux and using Python 3.6. I’ve tried this with Anaconda and also with vanilla python 3.6, none of them seem to work.

Did you build pytorch from source?

yes, still not working
Edit: Tried the same thing in a google cloud instance, still same errors

import torch

what does this say for you?

After completly removing torch and installing via build from source seems to be working for python 2.7 distribution. Thank you for your time!