What are the appropriate torch versions to use when using torch-tensorrt?

When I download torch==2.0.1, I am missing certain libtorch files to import torch_tensorrt. Namely:

from torch_tensorrt._C import dtype, DeviceType, EngineCapability, TensorFormat
ImportError: libtorch_cuda_cu.so: cannot open shared object file: No such file or directory

but when I revert to torch 1.13 as pip instructs me to it either automatically redownloads the latest torch, putting me back at square 1, or the boilerplate code for running tensorrt does not work. Would anyone be able to advise?

Double post from here.

Based on the Torch-TensorRT release notes it seems torch==1.13 is the latest supported version which is also being downloaded if I install torch_tensorrt==1.3.0:

Processing ./torch_tensorrt-1.3.0-cp310-cp310-linux_x86_64.whl
Collecting tensorrt<8.6.0,>=
  Downloading tensorrt- (549.5 MB)
     |████████████████████████████████| 549.5 MB 5.0 MB/s 
Collecting torch<1.14.0,>=1.13.0
  Downloading torch-1.13.1-cp310-cp310-manylinux1_x86_64.whl (887.5 MB)

CC @narendasan to correct me in case the support was extended.

thanks, this worked, with torchvision==0.14.0, still getting issue with the boilerplate code itself but this worked