Where cuda install in docker which I pull from docker hub

I pulled pytorch/pytorch:1.1.0-cuda10.0-cudnn7.5-runtime from dockerhub, I want to find where cuda install, it did not install /usr/local, I tried

find / -type d -name nvcc

and there is no output,
I also try

find / -type d -name cuda

there are some libs in python

Could you try to check the path using:

which nvcc

I tried,
it shows nvcc not found.
but I used

torch.version.cuda

it shows ‘10.0.130’,
And I run

nvidia-smi

it shows cuda version is 10.1

It looks like nvcc isn’t installed in the PyTorch docker image.
Could you try to pull the NVIDIA PyTorch docker container instead:

nvidia-docker run --rm -ti --ipc=host nvcr.io/nvidia/pytorch:19.05-py3

, which comes with CUDA10.1.

Let me know, if that would work for you.

@ngimel just explained, that you are using a runtime container, which does not come with nvcc. Instead you could pull a devel container using:

pytorch/pytorch:nightly-devel-cuda10.0-cudnn7

Could you try that?

nightly-devel-cuda10.0-cudnn7 version works, I found cuda-10.0 under /usr/local/ and nvcc installed in this version.
thank you very much.
but I am still confused where the cuda is installed in the pytorch/pytorch:1.1.0-cuda10.0-cudnn7.5-runtime, because

torch.version.cuda

tells me it has cuda10 but I can’t find it

In this container only the runtime is installed (without the compiler), similar to what you would get if you just install the PyTorch binaries with CUDA libs included.
While PyTorch will be able to run on you GPU, you won’t have the whole CUDA libs installed and cannot use nvcc out of the box.

got it, thank you very much!!!