Why does not my pycharm open?

I was working with pycharm that suddenly hangs. after that i cant run pycharm.Why this happened?While all the necessary tools are fully installed.
For example, when I run the following command in the terminal:
conda install pytorch torchvision -c soumith
I will get this answer:
pytorch 0.2.0 py36hf0d2509_4cu75 soumith
torchvision 0.1.9 py36h7584368_1 soumith

my ubuntu is 16.04 LST

I don’t know very much about pycharm, but have you tried killing all python processes before re-opening pycharm?

I’ve done the following steps:
1-Right-click the desktop and choose the Terminal option to open a terminal window.
2-Type the command sudo pkill python to kill all the Python processes running, regardless of the user who started the process. Type your password when prompted.
3-Type the command sudo pgrep python to ensure all Python processes have stopped. This command should not produce an output, and you will not be prompted for a password.
But unfortunately I did not get any results.what is your suggestion?
thank you for your attention

after restarting my system . I run the software again, this time ,Software first page opened and I was able to choose a new project to open, after the choice,the software did not open again.
The icon appears on the tool bar on the left side of the screen but nothing appears on the desktop.

Does this error appear randomly when you use Pycharm or just after importing Pytorch?

The graphical environment of the software does not open at all. After double clicking on the pycharm icon, i can see loading page Just for a few moments. After that, only the icons appear on the launcher and there is no access to anything

It sounds like a PyCharm issue to me. Have you asked on their forum already?
Unfortunately, I’m not using it, so I have no idea what it could be.

1 Like