Why test cases can't be all passed successfully?

Following the guide of https://github.com/pytorch/pytorch/blob/main/CONTRIBUTING.md#python-unit-testing documentation, I ran the command python test/run_test.py, during the run period, I can see failures frequently…

Also, for testing the specific test case, I tried the demo commands (like python test/test_jit.py TestJit.test_Sequential) in documentation, those are works fine, however according to the following section:

You can narrow down what you’re testing even further by specifying the name of an individual test with TESTCLASSNAME.TESTNAME. Here, TESTNAME is the name of the test you want to run, and TESTCLASSNAME is the name of the class in which it is defined.
I tried to execute the command python test/test_linalg.py TestLinalg.test_linalg_matrix_exp_boundary_cases, and the error occurred:

ERROR: TestLinalg (unittest.loader._FailedTest)
AttributeError: module '__main__' has no attribute 'TestLinalg'

Ran 1 test in 0.000s

FAILED (errors=1)

The problem here is that, when I tried to run all tests, I will always get the failures, and I don’t think that I should go through to fix those failed tests, because even for the unchanged clone repo, the results are the same.

For the single test case, still don’t know about how to fix to make it runnable, so can anyone give me some helps? Thanks!

Version info:
torch 2.0.0