HTTP error on google colab using torchvision.models

I’m trying to use google colab
but when I run the code


the HTTP error 403 : forbidden occurs
how can I fix it to use torchvision.models in google colab?
(It works good on my personal computer but not in google server)

It means torchvision isn’t able to connect to the pytorch servers. It usually happens when permissions are not made available to connect to the internet. Can you try downloading any other thing from it ? I don’t think it’s specific to torchvision.

I just tried several more other models using torchvision it still didn’t work…

and I tried to download other stuffs like image file using urllib.request, it worked good.

I think google server is blocking torchvision somehow

1 Like

@Yolkandwhite Thanks for letting us know.
We’ll look into this issue.

EDIT: related issue

1 Like

This seems to be CloudFlare doing terrible things – for no reason whatsoever with it’s “protection and caching layer”.

I’ve switched it off for now, and in ~4 hours or so, all requests should be direct again.

I’ll keep tabs on this thread to hear back if things are fixed.

Sorry about this whole mess.

1 Like

This problem resurfaced again today. It was working fine couple of days ago. Could you please look into it?

Related post with fix.