(Seeking help) The model does not appear in the "GRAPHS" with Tensorboard

Hi! I was learning to use the Tensorboard in PyTorch according to the tutorial in https://pytorch.org/tutorials/intermediate/tensorboard_tutorial.html.
I run the code within the Jupyter Notebook. The “IMAGES” can be visualized as expected. However, there were only two blank boxes in the “GRAPHS”, where the structure of the model was supposed to be shown.
The results are shown below.

Has anyone encountered this problem? I got stuck here for two days. I really don’t know what else I can do.
Thanks in advance for your help!


I am encountering the same issue, did you manage to solve it?

No, I haven’t got a solution yet. I still don’t know why. Now I kind of feel relieved to know that I am not alone :grinning:. Let’s wait for someone to help us.

This is apparently quite common, as I’m seeing it as well.
There are two open bug reports on it, the more useful of which is [this one.]

No known work-arounds.

I am curious if anyone at all has gotten this to work, and if so, what is different about our respective systems. The only thing I can think of that is remotely non-standard is that I run in a docker and on a remote Jupyter-lab, but that has never caused problems in the past.


I get the exact same behavior - two empty rectangles where the model graph should be.

Hi! i’m having the same issue, it’s seems to be some kind of bug, actually there are lot of people with the same problem. So it will be tackled soon or later.